PLANSWIFT
SUPPORT
Start a new topic

Move to 64-bit

Is there any plan to move Planswift to 64-bit?  Planswift offers too many options within the program to operate on 32-bit effectively. I love the versatility, just had the lag.


6 people like this idea

I've actually run into the issues with the built-in, unmodified tools as well. Once you've added in a couple joist layouts and labeled point counts, it'll slow it down significantly. I've stopped using labeled point counts because of it. I've altered the joist template so it doesn't show any labels or run calculations until the end when I request it.


Pretty much all my templates are pieces I've created over the last 5 years or so using PS. The worst thing I run into with my own templates is the amount of time it takes to load some of them because of how many parts there are. Again, fixing the 32/64-bit issue should fix that. Similarly, once I finish a job and move it to another folder, that can take forever too.


I do agree with you about the language. The basic stuff is pretty similar to Excel, so that wasn't too difficult to figure out. It's once I get into the scripting that I start to get in over my head a little bit. I've learned a little VBA for Excel macros, but not enough to be proficient. The help section seems to be a little lacking in that area for me.


When I've run into buggy parts and called in, assistance wasn't too helpful. They had a hard time replicating my issues and just ended up saying, "It must be your system." They were able to help me on a couple. At this point, I've just learned to work through the bugs.


By larger clients, I'm assuming they're referring to places like ProBuild and 84 Lumber who, I'm sure, are buying several licenses. I'm a small, single-license user as well.

If they do end up producing a 64 bit version, are there certain hardware specs that would be key to taking advantage of the change, or just have as much memory as possible?

You just need to have a 64 bit processor and be running on a 64 bit version of Windows. It also depends on which version of 64 bit Windows you are running. If you are on Windows 7 Home Basic, you're still limited to 8 GB. It's better than the 4 GB with 32 bit, but still not fantastic. Windows 7 Home Premium maxes out at 16 GB. Anything higher or later than that still has a limit, but nothing that most of us would come close to.

The type of memory will also play some part in it as well. DDR4 RAM is going to run faster than DDR3 RAM.

I think the trend in estimating software is moving towards a cloud based system, I have heard from previous employees from Plan Swift this is being considered. I have looked at a few of them and found they have an inherent flaw which is a cloud based system will not allow internal programing due to the threat of hackers and viruses.


Personally this ability to program within Plan Swift is what sets it apart.


Further it is my opinion that this lag in 64bit development is the chief reason they are traded like playing cards. I've watched them move through Textura through Oracle to here.


If they don't do something soon they will miss the opportunity and another will benefit. I have also heard that they keep patching fixes instead of rewriting code, every patch creates a bug, they fix the bug and another appears.. Their code is corrupt and bad management has let this happen. It almost seems like the wave has crashed and they are just ridding the whitewater to shore rather than turnaround and paddle back out for a better wave and a blue water ride.


Just saying.......


I hear ya on that Dave, The reproduction makes it easier to find the issue. If they cannot then they have to research their code and figure it out. I know this because I have someone very close to me, who outsourced a software he built (proprietary) (Also the patent only protects the first and last few lines of code by the way) to India and other countries told me about this because these issues happen and they need to get addressed. I had been talking to him about the issues I have had and the responses I got. Any how, I hope they are rewriting the code too as it has lot's of bugs. For instance, when you create an item in the advanced properties it jumps around and is not able to keep ion one place or the place you placed it. Simple things like that. The code should be able to keep it in place. I can go on and on.

Greg, the move to 64 bit is mainly for the software to be able to use more and more of your RAM in turn speeding up the software considerably. So if you have 4 gigs of ram then I get 8. I have 32 gigs and that's where the bottleneck happens.


Best,

I'm not a huge fan of the cloud based software either. Like you, I like being able to heavily modify my parts and pieces. I've done some coding for a few parts, but it's been pretty simple stuff. But, it makes things exponentially more convenient.

I've ran into some of those bugs as well, like advanced properties jumping around. But, if I need to pick and choose my battles, I can live with that. The one I've ran into more recently is, I have a few parts set up for my PVC trim (siding) that I have set up to either go by the measurements, or using a checkbox, can be converted so I can just set the quantity of each size I want. However, since then, there have been times where I use it for the measurements and if I copy and paste it to run multiple trim scenarios, the copy shows a length of 0 (leaving me with a QTY of 0). It's been completely inconsistent and when I notice it, it's a simple fix. I usually catch it, but it's slipped past me a few times and bit me in the butt... no bueno. I've created protocols to help avoid this from slipping past, but it would be nice to not have to worry about it. I know this is getting off into a tangent for another thread, so I will avoid going further down that rabbit hole.


Anyway, hopefully the recent increase in activity on this thread concerning the 64 bit issue will help make this a higher priority for one of the next updates. I will happily pay the upgrade (since I do not currently have the maintenance package) to get this update... and I will probably be able to convince my employer to get that upgrade package in the future along with it. Until then... I will make it work unless something much better comes along.

I have to ask the mundane... there are multiple ways to copy and past information.


To do what you are describing I would copy and paste through the Takeoff Summary, you will be asked if you want to copy the digitized information if you say no the quantities are not brought forward if you say yes the digitized information is brought forward and the digitation is copied on top of its self on the page .


If you copy and paste through the estimating tab you are not asked whether to copy digitized information,


if you copy on the Page tab you are asked to as if you want to create a new segment or continue the target segment, it is placed on the new page but there is no quantities just a continuation of the original tool.

Ron, I understand that. I'm talking about a different situation. I've copied it and chose to retain the digitizer points. All of that information is still there. However, it still returns my Qty as 0 even though there is information in the Linear Total. I have to go into the formula and make a change (like adding a space) to get it to update. I've also noticed that if I shut PS down and open it back up again, the quantities are usually updated. And, again, it's not consistent as to when it decides to do this.


The tool I'm thinking about does have a lot of expressions built into it. I'm not sure how much that may play into it. I'm sure it could be better consolidated using some scripting, but I'm not as proficient with that yet.


And I do get asked if I want to copy the digitizer points on both the Estimating tab and Pages tab. If you don't get it on there, you may have clicked "Do not ask again" one time and selected No. They may have changed that. But, that's how it works for me in v9.5.

Are there any updates from the Planswift team on the status of this project? It's been a year since we last heard from a team member.


I'm pleased to hear that the move to 64-bit is a huge priority for the team as this will provide a huge benefit to all of us using the software. I didn't notice much of any difference after applying the 4GB patch.

Problem with this is, that they have stated themselves that the move to 64-bit is a huge priority but over a year ago.... Obviously not that great of a priority... 

Dave, I ran into a similar situation when I started messing around moding my own templates, I would create copies of a my template and the Qty would show 0 even though there was Takeoff data and the formula in Qty was ok, I would have to ask planswift to Recalculate or do a small modification like adding a space to the Qty formula to make it do the calculation. Back then I used to have my templates show [Qty] in the formula of the property 'Name', why I don't exactly remember, but the case is that this was causing the problem and as soon as I removed it I never had the issue again. Hopes it helps. Also, like Ron mentioned, planswift has many ways to coping an item, and doing it a copy-and-paste either in Estimating Tab, Takeoff Summary or in page itself would hace diffent outcomes, each one very useful depending on what you want to accomplish, however I've notice that doing it in any of these three scenarios sometimes would not update the formulas in my templates, so up to date I would only use the Duplicate option available in the Takeoff Summary. That's the only way that my formulas would update

I work in a lumber company and we have 10 licenses and we are in need of the 64 bit really bad.

I spoke with Planswift outside sales person and he said its in the works.  I asked what the heck happened to be so bad on the programing and he explained the old owner was building systems to fit older work stations.  he was not ready to handle the updated equipment we have now.   There is a new company that owns Planswift now and they are supposed to be making things happen.    I'm impatiently waiting. ((


Login or Signup to post a comment