Can I install PlanSwift on a Mac? Yes, via Parallels or any Windows Emulator. However we suggest that you use Parallels.


You will need to make sure that your system meets the requirements for the Parallels software.


Basic requirements from Parallels include but are not limited to:

  • Mac OS® X Tiger 10.4 or higher running on an Intel® Mac.
  • Microsoft Windows XP, Vista, or Windows 7 (Not Included)


See full requirements Here



If you need assistance with Parallels, please contact Parallels Support.